aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-localserver
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-localserver')
-rw-r--r--community/py3-pytest-localserver/APKBUILD38
1 files changed, 26 insertions, 12 deletions
diff --git a/community/py3-pytest-localserver/APKBUILD b/community/py3-pytest-localserver/APKBUILD
index 3bcca9918b3..98b2df2385b 100644
--- a/community/py3-pytest-localserver/APKBUILD
+++ b/community/py3-pytest-localserver/APKBUILD
@@ -2,28 +2,42 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-pytest-localserver
_pyname=pytest-localserver
-pkgver=0.5.0
-pkgrel=3
+pkgver=0.8.1
+pkgrel=1
pkgdesc="a pytest plugin to test server connections locally"
-url="http://bitbucket.org/pytest-dev/pytest-localserver/"
+url="https://github.com/pytest-dev/pytest-localserver"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-setuptools_scm
+ py3-wheel
+ "
checkdepends="py3-pytest py3-six py3-requests py3-werkzeug"
-source="https://files.pythonhosted.org/packages/source/p/${_pyname}/${_pyname}-${pkgver}.tar.gz"
-builddir="${srcdir}/${_pyname}-${pkgver}"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
-check() {
- pytest-3
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="aedf1e1c9563396457070df13df228ad0ebdd19173fa2ac5a598288d3e1a1ac8b8a0c0288cba0d8478e43d2e1de4848f2393bf640705916957f12ab31171c6cc pytest-localserver-0.5.0.tar.gz"
+sha512sums="
+d0707d70b3c5caf346c7461cfca203f903277458596839cc2b1d1d48b6d1e6252e51ebcb9c21dc28fd3b98ce8368cb38e771c2a4226a5fc1dec4007f0b243cc2 pytest-localserver-0.8.1.tar.gz
+"