aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-mock/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-mock/APKBUILD')
-rw-r--r--community/py3-pytest-mock/APKBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/community/py3-pytest-mock/APKBUILD b/community/py3-pytest-mock/APKBUILD
index 1b9d761a073..5216edc810c 100644
--- a/community/py3-pytest-mock/APKBUILD
+++ b/community/py3-pytest-mock/APKBUILD
@@ -1,14 +1,21 @@
# Maintainer: Andy Postnikov <apostnikov@gmail.com>
pkgname=py3-pytest-mock
-pkgver=3.1.0
-pkgrel=0
+pkgver=3.10.0
+pkgrel=3
pkgdesc="Thin-wrapper around the mock package for easier use with py.test"
options="!check" # Fails
url="https://github.com/pytest-dev/pytest-mock"
arch="noarch"
license="MIT"
-depends="py3-pytest"
-makedepends="py3-setuptools"
+depends="
+ py3-mock
+ py3-pytest
+ "
+makedepends="
+ py3-setuptools
+ py3-setuptools_scm
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/pytest-mock/pytest-mock-$pkgver.tar.gz"
builddir="$srcdir/pytest-mock-$pkgver"
@@ -24,7 +31,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="6e970aeb1d4086df045a355e11969074e761fcdc3c8486e0405a4051cdf7c4425ae264e7005afe7afe5356f73061ad5f4cbad05b3ce2f55681a3e12ce1a6b671 pytest-mock-3.1.0.tar.gz"
+sha512sums="
+2ad6866d581a2999899e399ef5516d478a6172f52923f03703e3e3708229fb3b1178c91225b5cc90734c96abcb48fea517b11e0fc193da6fb592295395c14cd3 pytest-mock-3.10.0.tar.gz
+"