aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-mpi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-mpi/APKBUILD')
-rw-r--r--community/py3-pytest-mpi/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/py3-pytest-mpi/APKBUILD b/community/py3-pytest-mpi/APKBUILD
index f0a1560f8bc..be4b4a0d409 100644
--- a/community/py3-pytest-mpi/APKBUILD
+++ b/community/py3-pytest-mpi/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-pytest-mpi
-pkgver=0.5
-pkgrel=1
+pkgver=0.6
+pkgrel=2
pkgdesc="pytest plugin to collect information from tests"
url="https://pytest-mpi.readthedocs.io/en/latest/"
arch="noarch"
@@ -16,6 +16,7 @@ checkdepends="
py3-sybil
py3-pytest
"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/p/pytest-mpi/pytest-mpi-$pkgver.tar.gz"
options="!check" # Errors everywhere
builddir="$srcdir/pytest-mpi-$pkgver"
@@ -29,7 +30,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="900c6524bf271cbd26381cf3dbe89c02a1b201693fce22f142e887d874f36f8394c89e52545a386071032b4055b50e2399690a12981a1a239889f4bf4f140cff pytest-mpi-0.5.tar.gz"
+sha512sums="
+6de01394739effdd5cae8e5e519dd4346a6e5ccf4443dc295d0cfd3eb4b8267d2202a01da2f20b6f8fff6fbe18d6e9eb6094f38cb00eba87b336d5e9f26a57c0 pytest-mpi-0.6.tar.gz
+"