aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-runner/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-runner/APKBUILD')
-rw-r--r--community/py3-pytest-runner/APKBUILD35
1 files changed, 16 insertions, 19 deletions
diff --git a/community/py3-pytest-runner/APKBUILD b/community/py3-pytest-runner/APKBUILD
index 69f83ff0d45..e461bee67ae 100644
--- a/community/py3-pytest-runner/APKBUILD
+++ b/community/py3-pytest-runner/APKBUILD
@@ -1,37 +1,34 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
pkgname=py3-pytest-runner
-_pkgname=pytest-runner
-pkgver=5.3.1
-pkgrel=0
+pkgver=6.0.1
+pkgrel=1
pkgdesc="Invoke py.test as distutils command"
-options="!check" # Requires unpackaged pytest-{checkdocs,flake8,virtualenv}
url="https://github.com/pytest-dev/pytest-runner"
arch="noarch"
license="MIT"
-depends="python3 py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-prepare() {
- default_prepare
-
- sed -e '/setuptools_scm/d' -i setup.py -i setup.cfg
- sed -e "/^\[metadata\]/a version = $pkgver" -i setup.cfg
-}
+depends="python3 py3-pytest py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools_scm py3-wheel"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pytest-dev/pytest-runner/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/pytest-runner-$pkgver"
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 tests/test_ptr.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pytest_runner*.whl
}
sha512sums="
-7104ea8d714cc48fd69cbaedab5e71553889d1bc58b61bbb0d80a1de1cd9002eca2e05d6bc726c984ed4e4c4a276a757153164058295d445e458d763a888bcb6 pytest-runner-5.3.1.tar.gz
+4816954facf84015a2aa4c26e9f7c8e9de25f87d1320a9636a544c86b0be7d7da0f1336f4a4972c56643e1f13a92b2ee378a36ced7169a4ea64a32daa8c60618 py3-pytest-runner-6.0.1.tar.gz
"