aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-toolbox/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-toolbox/APKBUILD')
-rw-r--r--community/py3-pytest-toolbox/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/py3-pytest-toolbox/APKBUILD b/community/py3-pytest-toolbox/APKBUILD
index 12958199c8e..d40755a2a90 100644
--- a/community/py3-pytest-toolbox/APKBUILD
+++ b/community/py3-pytest-toolbox/APKBUILD
@@ -2,19 +2,21 @@
# Maintainer: Newbyte <newbyte@disroot.org>
pkgname=py3-pytest-toolbox
pkgver=0.4
-pkgrel=0
+pkgrel=5
pkgdesc="Numerous useful plugins for pytest"
url="https://github.com/samuelcolvin/pytest-toolbox"
arch="noarch"
license="MIT"
-depends="python3 py3-pytest-isort"
+depends="py3-pytest-isort py3-setuptools"
makedepends="py3-setuptools"
checkdepends="py3-pydantic py3-pytest py3-pytest-timeout"
+subpackages="$pkgname-pyc"
source="
$pkgname-v$pkgver.tar.gz::https://github.com/samuelcolvin/pytest-toolbox/archive/refs/tags/v$pkgver.tar.gz
yield-fixture.patch
"
builddir="$srcdir/pytest-toolbox-$pkgver/"
+options="!check" # fail on deprecation warning
build() {
python3 setup.py build
@@ -26,7 +28,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="