aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-vcr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-vcr/APKBUILD')
-rw-r--r--community/py3-pytest-vcr/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-pytest-vcr/APKBUILD b/community/py3-pytest-vcr/APKBUILD
new file mode 100644
index 00000000000..b0d529d18a0
--- /dev/null
+++ b/community/py3-pytest-vcr/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=py3-pytest-vcr
+pkgver=1.0.2
+pkgrel=4
+pkgdesc="py.test integration with vcr.py"
+url="https://github.com/ktosiek/pytest-vcr"
+arch="noarch"
+license="MIT"
+depends="python3 py3-vcrpy"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+options="!check" # tests not compattible with py3-pytest >= 5.0"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ktosiek/pytest-vcr/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/pytest-vcr-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+29dceb51092d73f2190b89e82e88b59506591a35cfe4f141bb877c05420d67a8ab2f21f63c2630972c35697d01b242891917d1be19b14fdfa810c1799f8542c2 py3-pytest-vcr-1.0.2.tar.gz
+"