aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pytest-xdist/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pytest-xdist/APKBUILD')
-rw-r--r--community/py3-pytest-xdist/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/py3-pytest-xdist/APKBUILD b/community/py3-pytest-xdist/APKBUILD
index 2576d9f2481..4df1e0d8018 100644
--- a/community/py3-pytest-xdist/APKBUILD
+++ b/community/py3-pytest-xdist/APKBUILD
@@ -1,15 +1,16 @@
# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
pkgname=py3-pytest-xdist
-pkgver=2.5.0
-pkgrel=0
+pkgver=3.5.0
+pkgrel=1
pkgdesc="pytest xdist plugin for distributed testing and loop-on-failing modes"
url="https://github.com/pytest-dev/pytest-xdist"
arch="noarch"
license="MIT"
-depends="py3-execnet py3-pytest py3-pytest-forked py3-six"
+depends="py3-execnet py3-pytest"
checkdepends="py3-filelock py3-py py3-pexpect py3-psutil"
-makedepends="py3-setuptools py3-setuptools_scm"
+makedepends="py3-gpep517 py3-setuptools py3-setuptools_scm py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/pytest-xdist/pytest-xdist-$pkgver.tar.gz"
builddir="$srcdir/pytest-xdist-$pkgver"
@@ -17,20 +18,22 @@ replaces="pytest-xdist" # Backwards compatibility
provides="pytest-xdist=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- mkdir -p tmp_py3
- python3 setup.py install --root="$builddir/tmp_py3" --optimize=1
- local _py3ver=$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
- PYTHONPATH="$builddir/tmp_py3/usr/lib/python$_py3ver/site-packages:$PYTHONPATH" python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/pytest_xdist*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pytest_xdist*.whl
}
sha512sums="
-22da4db7cdd6173fb8377b6adc30b5617ccb0bb308cb5d30980484dd7ddff87cf2a485ae8522c7957d8954dd2f8a5542b9f63b0fa7184cc44e50dbafc3f4e909 pytest-xdist-2.5.0.tar.gz
+1b6a896c6c69c110d1f3aa634740ffced570bbb788b3474687fef20147a5480a8681886b04db0413f7db68db546236f9a7f37e1592a74d1145f6eb6d876216ca pytest-xdist-3.5.0.tar.gz
"