aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-python-editor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-python-editor/APKBUILD')
-rw-r--r--community/py3-python-editor/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/community/py3-python-editor/APKBUILD b/community/py3-python-editor/APKBUILD
index 06bec1d8899..cb915c2b8d9 100644
--- a/community/py3-python-editor/APKBUILD
+++ b/community/py3-python-editor/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-python-editor
pkgver=1.0.4
-pkgrel=2
+pkgrel=8
pkgdesc="Programmatically open an editor, capture the result"
url="https://github.com/fmoo/python-editor"
arch="noarch"
@@ -10,7 +10,10 @@ license="Apache-2.0"
depends="python3"
makedepends="py3-setuptools"
options="!check" # tests are interactive
-source="https://files.pythonhosted.org/packages/source/p/python-editor/python-editor-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/python-editor/python-editor-$pkgver.tar.gz
+ distutils.patch
+ "
builddir="$srcdir/python-editor-$pkgver"
build() {
@@ -22,7 +25,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="c8ce2403bfe6c93935c7f4c384a8618a39cdaefe1ff5b1ff2cf4562866d8b3caa616e428c0a1634a56db934caeb474e7f84f8d5e009b9ed664189fdece8146f6 python-editor-1.0.4.tar.gz"
+sha512sums="
+c8ce2403bfe6c93935c7f4c384a8618a39cdaefe1ff5b1ff2cf4562866d8b3caa616e428c0a1634a56db934caeb474e7f84f8d5e009b9ed664189fdece8146f6 python-editor-1.0.4.tar.gz
+f9c872bf80e30a4f9a93d27ada61fbbe8aaa3a38d407e8bcbc154a5e0decb5bf315908b1f9ba36f917866771aaea51c8bb93a87a3d5b17e6839eda5587c5c14f distutils.patch
+"