aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-qt5/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-qt5/APKBUILD')
-rw-r--r--community/py3-qt5/APKBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/community/py3-qt5/APKBUILD b/community/py3-qt5/APKBUILD
index 54d49c0524b..46e466d1e7c 100644
--- a/community/py3-qt5/APKBUILD
+++ b/community/py3-qt5/APKBUILD
@@ -1,12 +1,12 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-qt5
-pkgver=5.15.6
-pkgrel=2
+pkgver=5.15.10
+pkgrel=1
pkgdesc="A set of Python 3 bindings for the Qt toolkit"
url="https://www.riverbankcomputing.com/software/pyqt/"
arch="all"
-license="GPL-3.0"
+license="GPL-3.0-only"
depends="
py3-pyqt5-sip
python3
@@ -21,6 +21,7 @@ makedepends="
qt5-qtbase-dev
qt5-qtconnectivity-dev
qt5-qtdeclarative-dev
+ qt5-qtlocation-dev
qt5-qtmultimedia-dev
qt5-qtserialport-dev
qt5-qtsvg-dev
@@ -29,21 +30,19 @@ makedepends="
qt5-qtwebsockets-dev
qt5-qtx11extras-dev
"
+subpackages="$pkgname-dbg $pkgname-pyc"
source="https://pypi.python.org/packages/source/P/PyQt5/PyQt5-$pkgver.tar.gz"
builddir="$srcdir/PyQt5-$pkgver"
-prepare() {
- default_prepare
- sed -i '/target_config.dbus_inc_dirs = \[\]/d' configure.py
-}
-
build() {
+ export CFLAGS="$CFLAGS -O2 -flto=auto"
+ export CXXFLAGS="$CXXFLAGS -O2 -flto=auto"
sip-build \
--confirm-license \
--qmake /usr/lib/qt5/bin/qmake \
--api-dir /usr/share/qt5/qsci/api/python \
+ --pep484-pyi \
--no-make
-# find . -name 'Makefile' -print0 | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
make -C build
}
@@ -53,8 +52,9 @@ check() {
package() {
make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" -C build install -j1
+ python3 -m compileall -j 0 "$pkgdir"/usr/lib/python3*
}
sha512sums="
-65fd663cb70e8701e49bd4b39dc9384546cf2edd1b3bab259ca64b50908f48bdc02ca143f36cd6b429075f5616dcc7b291607dcb63afa176e828cded3b82f5c7 PyQt5-5.15.6.tar.gz
+e62debe112210b68993377264448199b66a43fc5db13c583a25e210759f5cd945bd1056c1c19fb86bcf005c6904358dfb89e005d27167a349f1d55987a63013e PyQt5-5.15.10.tar.gz
"