aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-quantiphy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-quantiphy/APKBUILD')
-rw-r--r--community/py3-quantiphy/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/py3-quantiphy/APKBUILD b/community/py3-quantiphy/APKBUILD
index 49b19de248f..23d50255421 100644
--- a/community/py3-quantiphy/APKBUILD
+++ b/community/py3-quantiphy/APKBUILD
@@ -1,27 +1,34 @@
# Contributor: Andy Hawkins <andy@gently.org.uk>
# Maintainer: Andy Hawkins <andy@gently.org.uk>
pkgname=py3-quantiphy
-pkgver=2.14
-pkgrel=0
+pkgver=2.19
+pkgrel=2
pkgdesc="Physical Quantities"
url="https://quantiphy.readthedocs.io/"
arch="noarch"
-license="GPL-3.0-or-later"
+license="MIT"
depends="
python3
"
makedepends="
- py3-setuptools
+ py3-gpep517
+ py3-flit-core
"
checkdepends="
py3-pytest
+ py3-pytest-cov
py3-inform
+ py3-parametrize-from-file
+ py3-voluptuous
"
+subpackages="$pkgname-pyc"
source="https://github.com/KenKundert/quantiphy/archive/v$pkgver/quantiphy-v$pkgver.tar.gz"
builddir="$srcdir/quantiphy-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -30,8 +37,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/quantiphy-$pkgver*.whl
}
+
sha512sums="
-a3e60eca71df3555b4ce726218fecf098d521929c11694ab2280ce52c7fc7f9d75209551cd11f251ddad88269dee7d3376ea7c36f7a2b77390e096f5003532cc quantiphy-v2.14.tar.gz
+8f76a493997ff51d325ad6e043c12cf0ea272cd1962cf7a9d3b354b2eb2d3c581eda4b3e291b174ba2fe7a1f2f151ed2720c16b9c428e03c22705afb74418755 quantiphy-v2.19.tar.gz
"