aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rasterio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rasterio/APKBUILD')
-rw-r--r--community/py3-rasterio/APKBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/community/py3-rasterio/APKBUILD b/community/py3-rasterio/APKBUILD
index 0e8564de18f..b022c2a459a 100644
--- a/community/py3-rasterio/APKBUILD
+++ b/community/py3-rasterio/APKBUILD
@@ -1,12 +1,11 @@
# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
pkgname=py3-rasterio
-pkgver=1.2.6
-pkgrel=0
+pkgver=1.3.9
+pkgrel=2
pkgdesc="Fast and direct raster I/O for use with Numpy and SciPy"
-url="https://pypi.python.org/pypi/rasterio"
-# missing openjdk8 on riscv64
-arch="all !s390x !x86 !armhf !armv7 !mips !mips64 !riscv64"
+url="https://pypi.org/project/rasterio"
+arch="all"
license="BSD-3-Clause"
depends="
py3-affine
@@ -17,25 +16,24 @@ depends="
py3-cligj
py3-matplotlib
py3-numpy
+ py3-setuptools
py3-snuggs
"
makedepends="
cython
gdal-dev
- gdal-tools
py3-numpy-dev
python3-dev
"
checkdepends="
+ gdal-driver-HDF5
+ gdal-tools
pytest
- py3-pip
py3-hypothesis
- py3-sphinx
py3-shapely
"
-source="
- rasterio-$pkgver.tar.gz::https://github.com/mapbox/rasterio/archive/$pkgver.tar.gz
- "
+subpackages="$pkgname-pyc"
+source="rasterio-$pkgver.tar.gz::https://github.com/mapbox/rasterio/archive/$pkgver.tar.gz"
builddir="$srcdir/rasterio-$pkgver"
build() {
@@ -47,9 +45,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=2
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-a220c93beae892734cb62bd0bad9f33f5af92ba1fd4362dc4cc8b6aeb236dbc0431f07123894c2d8dbaa20b24ce8b6647abda87d0ec1415c64d11fb9dc0e2e4e rasterio-1.2.6.tar.gz
+4e360446acdd8b243fa8acae38f9351c48fcb8ca99068fd547c92654a786dc3bd81f7e96147786686d95b786a366b3fdd4554f45ab23208a3a874c208f2a4e8f rasterio-1.3.9.tar.gz
"