aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rasterio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rasterio/APKBUILD')
-rw-r--r--community/py3-rasterio/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/community/py3-rasterio/APKBUILD b/community/py3-rasterio/APKBUILD
index f32ed498083..385b4e58b1f 100644
--- a/community/py3-rasterio/APKBUILD
+++ b/community/py3-rasterio/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
pkgname=py3-rasterio
-pkgver=1.2.1
-pkgrel=1
+pkgver=1.3.9
+pkgrel=3
pkgdesc="Fast and direct raster I/O for use with Numpy and SciPy"
-url="https://pypi.python.org/pypi/rasterio"
-arch="all !s390x !x86 !armhf !armv7 !mips !mips64"
+url="https://pypi.org/project/rasterio"
+arch="all"
license="BSD-3-Clause"
depends="
py3-affine
@@ -16,24 +16,24 @@ depends="
py3-cligj
py3-matplotlib
py3-numpy
+ py3-setuptools
py3-snuggs
"
makedepends="
cython
gdal-dev
- gdal-tools
py3-numpy-dev
python3-dev
"
checkdepends="
+ gdal-driver-HDF5
+ gdal-tools
pytest
py3-hypothesis
- py3-sphinx
py3-shapely
"
-source="
- rasterio-$pkgver.tar.gz::https://github.com/mapbox/rasterio/archive/$pkgver.tar.gz
- "
+subpackages="$pkgname-pyc"
+source="rasterio-$pkgver.tar.gz::https://github.com/mapbox/rasterio/archive/$pkgver.tar.gz"
builddir="$srcdir/rasterio-$pkgver"
build() {
@@ -45,7 +45,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=2
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="6fa3aaf3a82f577216e153b2a7e957a9c789ee2822ae02cf43c5e333849f353d10f6c495b17ae7254279f26e9fc54b30c6f071d0493809ad83edc119c7ce846b rasterio-1.2.1.tar.gz"
+sha512sums="
+4e360446acdd8b243fa8acae38f9351c48fcb8ca99068fd547c92654a786dc3bd81f7e96147786686d95b786a366b3fdd4554f45ab23208a3a874c208f2a4e8f rasterio-1.3.9.tar.gz
+"