aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-raven/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-raven/APKBUILD')
-rw-r--r--community/py3-raven/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/community/py3-raven/APKBUILD b/community/py3-raven/APKBUILD
index 144b3257227..5d709244ec7 100644
--- a/community/py3-raven/APKBUILD
+++ b/community/py3-raven/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-raven
_pkgname=raven
pkgver=6.10.0
-pkgrel=3
+pkgrel=7
pkgdesc="Python client for Sentry"
url="https://github.com/getsentry/raven-python"
arch="noarch"
@@ -12,22 +12,22 @@ replaces="py-raven py2-raven" # for backwards compatibility
provides="py-raven=$pkgver-r$pkgrel py2-raven=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
makedepends="py3-setuptools python3-dev"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py check
}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="37ca6d5953dc92b57b3bf4e2edb3947d41f33711d9babfc9eafb8712dc5923829f8810e5123e63749710aeecceb66e56bf8b5b60868f61d750704e20add3c747 raven-6.10.0.tar.gz"
+sha512sums="
+37ca6d5953dc92b57b3bf4e2edb3947d41f33711d9babfc9eafb8712dc5923829f8810e5123e63749710aeecceb66e56bf8b5b60868f61d750704e20add3c747 raven-6.10.0.tar.gz
+"