aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rdflib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rdflib/APKBUILD')
-rw-r--r--community/py3-rdflib/APKBUILD56
1 files changed, 43 insertions, 13 deletions
diff --git a/community/py3-rdflib/APKBUILD b/community/py3-rdflib/APKBUILD
index cf6d964807f..343d4f16a97 100644
--- a/community/py3-rdflib/APKBUILD
+++ b/community/py3-rdflib/APKBUILD
@@ -1,30 +1,60 @@
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname=py3-rdflib
_pyname=rdflib
-pkgver=5.0.0
+pkgver=7.0.0
pkgrel=1
pkgdesc="A Python library for working with RDF, a simple yet powerful language for representing information"
url="https://rdflib.readthedocs.org/"
-arch="noarch !s390x" # tests fail with segfault
+arch="noarch"
license="BSD-3-Clause"
-depends="py3-isodate py3-parsing"
-checkdepends="py3-nose py3-html5lib py3-sparqlwrapper py3-doctest-ignore-unicode py3-requests"
-makedepends="py3-setuptools"
-_pypiprefix="${_pyname%${_pyname#?}}"
-source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+depends="
+ py3-isodate
+ py3-parsing
+ "
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-poetry-core
+ "
+checkdepends="
+ py3-doctest-ignore-unicode
+ py3-html5lib
+ py3-pytest
+ py3-pytest-cov
+ py3-requests
+ py3-sparqlwrapper
+ "
+subpackages="$pkgname-pyc"
+source="https://github.com/RDFLib/rdflib/archive/refs/tags/$pkgver/rdflib-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # sparql service updated so skip some tests
- # https://github.com/RDFLib/rdflib/issues/1229
- nosetests --exclude "test_sparql_service"
+ case "$CARCH" in
+ armhf|armv7|x86)
+ _skip_hash_test="--deselect=test/test_extras/test_infixowl/test_restriction.py::test_restriction_str_and_hash"
+ ;;
+ esac
+ python3 -m venv --clear --without-pip --system-site-packages test-env
+ test-env/bin/python3 -m installer .dist/*.whl
+ # exclude failing test
+ # https://github.com/RDFLib/rdflib/issues/2748
+ test-env/bin/python3 -m pytest \
+ --ignore="test/test_so_69984830.py" \
+ --ignore="test/test_misc/test_plugins.py" \
+ --deselect="test/test_misc/test_parse_file_guess_format.py" \
+ $_skip_hash_test
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
-sha512sums="ba98ab6a7bb9d993d11c559a739761f297282eb9307f3e333db8dd1c6b365b408a59b701d823bef9be774a59b3f44f64c9444e3bb0115c0c549cb00945385dab rdflib-5.0.0.tar.gz"
+sha512sums="
+176192bd2ce8a400e661ced2e21e3dd35783fa1c6c8390f6dee4ac61ca63da5d3a50df3d287f47783631da12452ca3ec92ad06050417029396fe8b3ab0182041 rdflib-7.0.0.tar.gz
+"