aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rencode/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rencode/APKBUILD')
-rw-r--r--community/py3-rencode/APKBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/community/py3-rencode/APKBUILD b/community/py3-rencode/APKBUILD
index 411f8298e28..6309f7ccc73 100644
--- a/community/py3-rencode/APKBUILD
+++ b/community/py3-rencode/APKBUILD
@@ -3,25 +3,34 @@
pkgname=py3-rencode
_pkgname=rencode
pkgver=1.0.6
-pkgrel=4
+pkgrel=11
pkgdesc="The rencode module is similar to bencode from the BitTorrent project."
options="!check" # No testsuite
-url="https://pypi.python.org/pypi/rencode"
+url="https://pypi.org/project/rencode"
arch="all"
license="GPL-3.0-or-later"
-makedepends="py3-setuptools python3-dev cython"
-source="$pkgname-$pkgver.tar.gz::https://github.com/aresch/rencode/archive/v$pkgver.tar.gz"
+makedepends="py3-setuptools py3-wheel python3-dev cython"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/aresch/rencode/archive/v$pkgver.tar.gz
+ CVE-2021-40839.patch"
builddir="$srcdir"/$_pkgname-$pkgver
replaces="py-rencode" # Backwards compatibility
provides="py-rencode=$pkgver-r$pkgrel" # Backwards compatibility
+# secfixes:
+# 1.0.6-r7:
+# - CVE-2021-40839
+
build() {
python3 setup.py build
}
package() {
- python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+ python3 setup.py --quiet install --skip-build --root="$pkgdir"
}
-sha512sums="f04de4d3a83aed916bdc4b7a8ca772655e9324d0531ee882cb7d2a1e92b397bdcec8497bf02939e0a806886ecc62ed2e7319dfee054dad1b69052157f0959e8f py3-rencode-1.0.6.tar.gz"
+sha512sums="
+f04de4d3a83aed916bdc4b7a8ca772655e9324d0531ee882cb7d2a1e92b397bdcec8497bf02939e0a806886ecc62ed2e7319dfee054dad1b69052157f0959e8f py3-rencode-1.0.6.tar.gz
+47eeb3e9e7d1c728b68fc4d3abc1c9a45dae592e6fc0edd1cf77514952100fd8a997a2a5bd899e32ec0c34f2f206fe7d1bf529111188682cb1abe6650f39b1c7 CVE-2021-40839.patch
+"