aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-repoze-lru/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-repoze-lru/APKBUILD')
-rw-r--r--community/py3-repoze-lru/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-repoze-lru/APKBUILD b/community/py3-repoze-lru/APKBUILD
new file mode 100644
index 00000000000..18f74f96eed
--- /dev/null
+++ b/community/py3-repoze-lru/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Duncan Bellamy <dunk@denkimushi.com>
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
+pkgname=py3-repoze-lru
+_pkgname=repoze.lru
+pkgver=0.7
+pkgrel=6
+pkgdesc="A tiny LRU cache implementation and decorator"
+url="https://repoze.readthedocs.io/en/latest/"
+arch="noarch"
+license="custom"
+depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-doc $pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/r/repoze.lru/repoze.lru-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+ install -Dm644 "$builddir"/LICENSE.txt \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="c4d8b015931c4265fa8559f99c9d5016835574b368ebe0d49fe503afe908020b2bf29836606134e00c6c0aa436d52a00bb73d6ab80e98d0802f54bd2e4686476 py3-repoze-lru-0.7.tar.gz"