aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-requests-cache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-requests-cache/APKBUILD')
-rw-r--r--community/py3-requests-cache/APKBUILD48
1 files changed, 32 insertions, 16 deletions
diff --git a/community/py3-requests-cache/APKBUILD b/community/py3-requests-cache/APKBUILD
index 51d40eedfc8..ac21aafd658 100644
--- a/community/py3-requests-cache/APKBUILD
+++ b/community/py3-requests-cache/APKBUILD
@@ -1,45 +1,61 @@
# Contributor: Philipp Glaum <p@pglaum.de>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-requests-cache
-pkgver=0.6.3
+pkgver=1.0.1
pkgrel=0
pkgdesc="Persistent cache for requests library"
-url="https://pypi.org/project/requests-cache/"
+url="https://github.com/requests-cache/requests-cache"
arch="noarch"
license="BSD-3-Clause"
depends="
+ py3-attrs
+ py3-cattrs
+ py3-platformdirs
py3-requests
py3-url-normalize
- python3
+ py3-urllib3
+ "
+makedepends="
+ py3-gpep517
+ py3-poetry-core
+ py3-wheel
"
-makedepends="py3-setuptools"
checkdepends="
py3-itsdangerous
py3-mock
+ py3-mongo
+ py3-msgpack
+ py3-orjson
py3-pytest
+ py3-pytest-xdist
py3-requests-mock
+ py3-responses
+ py3-rich
py3-timeout-decorator
+ py3-ujson
+ py3-yaml
"
-source="https://pypi.python.org/packages/source/r/requests-cache/requests-cache-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/requests-cache/requests-cache/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/requests-cache-$pkgver"
-prepare() {
- default_prepare
- # Invoke python3
- sed -i "s|os.system('python %s' % test)|os.system('python3 %s' % test)|" setup.py
-}
-
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # integration tests skipped as they require running databases
- pytest --ignore tests/integration
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto --ignore tests/integration
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="d2ebba52b21d4c733f3fba8fbdb9b839197bb2aacfa0b272d41dd06f8be7766c8eedcc19c12d30e901eebdd595beaa02a6c2d303b54e23069a3635f77217c2df requests-cache-0.6.3.tar.gz"
+sha512sums="
+ec5788e31f60fd95e575d01af1163f981757972db6557d7a62da2ca0719e84262cf66cdd9b40c73cca540b92d6b7f6beba1aa42bedba528734c61edf5013ec3d py3-requests-cache-1.0.1.tar.gz
+"