aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-retrying/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-retrying/APKBUILD')
-rw-r--r--community/py3-retrying/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/py3-retrying/APKBUILD b/community/py3-retrying/APKBUILD
index e4261402c8c..20b3e43672a 100644
--- a/community/py3-retrying/APKBUILD
+++ b/community/py3-retrying/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
pkgname=py3-retrying
pkgver=1.3.3
-pkgrel=1
+pkgrel=5
pkgdesc="General purpose Python3 retrying library"
url="https://github.com/rholder/retrying/releases"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-six"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/rholder/retrying/archive/v$pkgver.tar.gz"
builddir="$srcdir/retrying-$pkgver"
@@ -21,7 +22,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="e053e62cb71b31573b89b8fffa706c3410794b5cced829582c373a09af78158f7a16948e6ce52078589cf7d8f5bba726c889180588a2628be343f242bc40c035 py3-retrying-1.3.3.tar.gz"