aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rfc3986/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rfc3986/APKBUILD')
-rw-r--r--community/py3-rfc3986/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/community/py3-rfc3986/APKBUILD b/community/py3-rfc3986/APKBUILD
index b1ae8c51c31..f8dae695829 100644
--- a/community/py3-rfc3986/APKBUILD
+++ b/community/py3-rfc3986/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: omni <omni+alpine@hack.org>
pkgname=py3-rfc3986
_pkgname=rfc3986
-pkgver=1.4.0
-pkgrel=1
+pkgver=2.0.0
+pkgrel=2
pkgdesc="implementation of RFC 3986 including validation & authority parsing"
url="https://rfc3986.readthedocs.io/en/latest/"
arch="noarch"
@@ -22,10 +22,12 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
# find and remove directory containing pyc files
find "$pkgdir" -name '__pycache__' -type d -exec rm -rf {} +
}
-sha512sums="c13e30786bc3771cc1c5bd8dc597ebf475b1127d46cb3b9147c381198959eba4582e2448091462757e89b2e13c352680784979d3f6e52a8d87d48666bd3866cd py3-rfc3986-1.4.0.tar.gz"
+sha512sums="
+6ca171868a625d893e928be013f5369be08d631bf13a293f9f6c3dc1099d73808bb44e1cee7a5d9823da9d5cf282a85afd0df853bb342849d5d40a315c7bd7b5 py3-rfc3986-2.0.0.tar.gz
+"