aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rich/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rich/APKBUILD')
-rw-r--r--community/py3-rich/APKBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/community/py3-rich/APKBUILD b/community/py3-rich/APKBUILD
index 3c3cbb80504..8081d7eb00d 100644
--- a/community/py3-rich/APKBUILD
+++ b/community/py3-rich/APKBUILD
@@ -1,32 +1,38 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-rich
-_pkgname=rich
-pkgver=10.3.0
+pkgver=13.7.1
pkgrel=0
pkgdesc="Python library for rich text formatting and terminal formatting"
-options="!check" # Testsuite not present in pypi tarball and uses poetry
url="https://rich.readthedocs.io/en/latest/"
arch="noarch"
license="MIT"
depends="
- py3-colorama
- py3-commonmark
+ py3-markdown-it-py
py3-pygments
- py3-typing-extensions
"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+makedepends="py3-gpep517 py3-installer py3-poetry-core py3-wheel"
+checkdepends="py3-pytest py3-setuptools"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/willmcgugan/rich/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/rich-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 1>&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -k 'not test_python_render_simple_indent_guides and not test_python_render_line_range_indent_guides'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-32c8cac30f5b1bfc5ed038136b0393bbb0b65d8e864def1aac2b5ea88d532969a79602f881ffd4603b543c434e84901844c8a941a3f976caf187440ad565cc06 rich-10.3.0.tar.gz
+0c69101bc6c2a238a4c516812cda08299115b903b8282ee348b45b212a88fcbfbf69d11a3705a97bdb6192988ee3047804bb5b52b7950d860542cde8ce2d4bd2 py3-rich-13.7.1.tar.gz
"