aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rich/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rich/APKBUILD')
-rw-r--r--community/py3-rich/APKBUILD35
1 files changed, 16 insertions, 19 deletions
diff --git a/community/py3-rich/APKBUILD b/community/py3-rich/APKBUILD
index 79456bea303..e335a2c42b1 100644
--- a/community/py3-rich/APKBUILD
+++ b/community/py3-rich/APKBUILD
@@ -1,41 +1,38 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: psykose <alice@ayaya.dev>
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-rich
-_pkgname=rich
-pkgver=12.4.4
-pkgrel=0
+pkgver=13.7.1
+pkgrel=1
pkgdesc="Python library for rich text formatting and terminal formatting"
url="https://rich.readthedocs.io/en/latest/"
arch="noarch"
license="MIT"
depends="
- py3-colorama
- py3-commonmark
+ py3-markdown-it-py
py3-pygments
- py3-typing-extensions
- python3
"
-makedepends="py3-build py3-installer py3-poetry-core py3-wheel"
-checkdepends="py3-pytest"
+makedepends="py3-gpep517 py3-installer py3-poetry-core py3-wheel"
+checkdepends="py3-pytest py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/willmcgugan/rich/archive/refs/tags/v$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+builddir="$srcdir/rich-$pkgver"
build() {
- # XXX: hack for poetry to not ignore files
- GIT_DIR=. python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 1>&2
}
check() {
- python3 -m installer -d testenv dist/rich-$pkgver-py3-none-any.whl
- local sitedir="$(python3 -c 'import site;print(site.getsitepackages()[0])')"
-
- PYTHONPATH="$PWD/testenv/$sitedir" python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -k 'not test_python_render_simple_indent_guides and not test_python_render_line_range_indent_guides'
}
package() {
- python3 -m installer -d "$pkgdir" dist/rich-$pkgver-py3-none-any.whl
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-c1d077bb1448fd436fea87697d31b484615f787c9259418d6ebd12da45bf14f25f192198e4522653c5bd4e5ba218da7d72597e20d04dbffce4a3ea8bd82ce27c py3-rich-12.4.4.tar.gz
+0c69101bc6c2a238a4c516812cda08299115b903b8282ee348b45b212a88fcbfbf69d11a3705a97bdb6192988ee3047804bb5b52b7950d860542cde8ce2d4bd2 py3-rich-13.7.1.tar.gz
"