aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rich/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rich/APKBUILD')
-rw-r--r--community/py3-rich/APKBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/community/py3-rich/APKBUILD b/community/py3-rich/APKBUILD
index dac425328af..e335a2c42b1 100644
--- a/community/py3-rich/APKBUILD
+++ b/community/py3-rich/APKBUILD
@@ -1,36 +1,38 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-rich
-_pkgname=rich
-pkgver=10.6.0
-pkgrel=0
+pkgver=13.7.1
+pkgrel=1
pkgdesc="Python library for rich text formatting and terminal formatting"
url="https://rich.readthedocs.io/en/latest/"
arch="noarch"
license="MIT"
depends="
- py3-colorama
- py3-commonmark
+ py3-markdown-it-py
py3-pygments
- py3-typing-extensions
"
-makedepends="pyproject2setuppy"
-checkdepends="py3-pytest"
+makedepends="py3-gpep517 py3-installer py3-poetry-core py3-wheel"
+checkdepends="py3-pytest py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/willmcgugan/rich/archive/refs/tags/v$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+builddir="$srcdir/rich-$pkgver"
build() {
- python3 -m pyproject2setuppy.main build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 1>&2
}
check() {
- PYTHONPATH="$PWD/build/lib" py.test-3 -v
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -k 'not test_python_render_simple_indent_guides and not test_python_render_line_range_indent_guides'
}
package() {
- python3 -m pyproject2setuppy.main install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-59b777ef0fe3efe67138a7dbfc0c4e813b0a8c3d46adc6526b07241483919e0f71b478c0a66f3e0c207fcebdc0d639b7acf989ebf914c0e0fb6953029f0c9a16 py3-rich-10.6.0.tar.gz
+0c69101bc6c2a238a4c516812cda08299115b903b8282ee348b45b212a88fcbfbf69d11a3705a97bdb6192988ee3047804bb5b52b7950d860542cde8ce2d4bd2 py3-rich-13.7.1.tar.gz
"