aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rope/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rope/APKBUILD')
-rw-r--r--community/py3-rope/APKBUILD34
1 files changed, 25 insertions, 9 deletions
diff --git a/community/py3-rope/APKBUILD b/community/py3-rope/APKBUILD
index 8491879940c..affa917b8de 100644
--- a/community/py3-rope/APKBUILD
+++ b/community/py3-rope/APKBUILD
@@ -1,29 +1,45 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-rope
-pkgver=0.20.0
-pkgrel=0
+pkgver=1.13.0
+pkgrel=1
pkgdesc="Python refactoring library"
url="https://github.com/python-rope/rope"
arch="noarch"
license="LGPL-3.0-only"
-depends="python3"
-makedepends="py3-setuptools"
-source="https://github.com/python-rope/rope/archive/$pkgver/rope-$pkgver.tar.gz"
+depends="py3-pytoolconfig py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
+checkdepends="
+ py3-build
+ py3-pip
+ py3-pytest
+ "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/python-rope/rope/archive/refs/tags/$pkgver.tar.gz"
+options="net" # required for tests
builddir="$srcdir/rope-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m unittest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # test_search_submodule fails to find env from py3-build
+ .testenv/bin/python3 -m pytest -k 'not test_search_submodule'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-2c05d68b2bdfca7d8f29798e24ba92984c1e5db45b61173160c915c68e3cdb527c4b265f69eeb971ad4f774c33b506feaebf5ce0068aa2fd9f1d062e002b86e4 rope-0.20.0.tar.gz
+fae1555570997164d14ae8a6541750544b14c2aefd49e77d45585e47550a3c62c734bdfa28cbdcbcaa4c4d3c7a6a0ecf6ff3c116c47d2888ba71c311fe424157 py3-rope-1.13.0.tar.gz
"