aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rply/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rply/APKBUILD')
-rw-r--r--community/py3-rply/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-rply/APKBUILD b/community/py3-rply/APKBUILD
new file mode 100644
index 00000000000..dcb3f234e5f
--- /dev/null
+++ b/community/py3-rply/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Newbyte <newbyte@disroot.org>
+pkgname=py3-rply
+pkgver=0.7.8
+pkgrel=5
+pkgdesc="Python parser generator, that also works with RPython"
+url="https://github.com/alex/rply"
+arch="noarch"
+license="BSD-3-Clause-Clear"
+depends="py3-appdirs"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-runner"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/alex/rply/archive/v$pkgver.tar.gz"
+builddir="$srcdir/rply-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ py.test-3
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="b43e6425f046561cfca616801d37d7151f015aeb2ea2365abc00f97fd6b41f1a01a17e330aed5a81537065e4b29d49cd0824b5a5cb8b2d11da2ff1f8de952fce py3-rply-0.7.8.tar.gz"