aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rsa/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rsa/APKBUILD')
-rw-r--r--community/py3-rsa/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/community/py3-rsa/APKBUILD b/community/py3-rsa/APKBUILD
index ba5f24f5e4b..d4ad9f1dd37 100644
--- a/community/py3-rsa/APKBUILD
+++ b/community/py3-rsa/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-rsa
_pkgname=rsa
-pkgver=4.7
-pkgrel=2
+pkgver=4.9
+pkgrel=3
pkgdesc="Pure-Python3 RSA implementation"
url="https://stuvel.eu/rsa"
arch="noarch"
@@ -11,8 +11,10 @@ license="Apache-2.0"
depends="python3 py3-asn1"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-mock py3-mypy"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/r/rsa/rsa-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+options="!check" # no tests in pypi tarball
replaces="py-rsa" # Backwards compatibility
provides="py-rsa=$pkgver-r$pkgrel" # Backwards compatibility
@@ -26,7 +28,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="3a5f4df0f5a83aa3b99d3072a6c1e3d038c778892ad5aa329081fe736242f839827921e588adfdf004afc546fcbd1dabb14cba5543f25374c026c34392d94c47 rsa-4.7.tar.gz"
+sha512sums="
+85f359cc448a42f267f425fcf761597eeeab942523de49284b01d6ea2bcca8bddf0fac26926b487ae91c15889a7c4897a33ee00de859f28fe9cca19ef98c3f19 rsa-4.9.tar.gz
+"