aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ruamel.std.pathlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ruamel.std.pathlib/APKBUILD')
-rw-r--r--community/py3-ruamel.std.pathlib/APKBUILD33
1 files changed, 22 insertions, 11 deletions
diff --git a/community/py3-ruamel.std.pathlib/APKBUILD b/community/py3-ruamel.std.pathlib/APKBUILD
index a9a009b23ac..d2a19413de5 100644
--- a/community/py3-ruamel.std.pathlib/APKBUILD
+++ b/community/py3-ruamel.std.pathlib/APKBUILD
@@ -2,30 +2,41 @@
# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-ruamel.std.pathlib
_pyname=ruamel.std.pathlib
-pkgver=0.6.4
+pkgver=0.12.0
pkgrel=2
pkgdesc="improvements over the standard pathlib module and pathlib2 package"
-url=https://bitbucket.org/ruamel/std.pathlib
+url="https://sourceforge.net/projects/ruamel-std-pathlib/"
arch=noarch
license=MIT
depends="python3"
-makedepends="py3-setuptools py3-pip"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="py3-pytest"
-source="https://files.pythonhosted.org/packages/81/90/3d1c9b51b99626f91c7afb17eeed6a46a213701b232dc61d3b40edc8635c/ruamel.std.pathlib-${pkgver}.tar.gz
- python3.7.patch"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.xz::https://sourceforge.net/projects/ruamel-dl-tagged-releases/files/ruamel.std.pathlib-$pkgver.tar.xz/download"
builddir="$srcdir/ruamel.std.pathlib-$pkgver"
-options="!check"
+options="!check" # todo: json.dumps not found
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH=build/lib python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 -m pip install . --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="450c3018a85a8fdfc4769e9cb88025a314f4db2980b2cf8290e12944785b570f4c719b3db419e6b1de5186dd72fdbb4a3b2d0a599181da162c1ec5c2fc7138b3 ruamel.std.pathlib-0.6.4.tar.gz
-51b2c1cebec4cefca455ba3f744f1dc40d2b2243b7df1d8911a5fd4f214c295f949b8556953a00c3a5c542f8bedccd2260466fd5c19f033572cd0f91504b80fd python3.7.patch"
+
+sha512sums="
+07c969d95fa3ebcf2e5070aa50044760fa1198d189f2d4104bfbaf9b49884deb391e32db2b4ffa23e5ed7d192c4a010c76d7ecc0cbe7f321cdc449f9a89f12be py3-ruamel.std.pathlib-0.12.0.tar.xz
+"