aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ruamel.yaml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ruamel.yaml/APKBUILD')
-rw-r--r--community/py3-ruamel.yaml/APKBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/community/py3-ruamel.yaml/APKBUILD b/community/py3-ruamel.yaml/APKBUILD
index c8627621660..9cae468c899 100644
--- a/community/py3-ruamel.yaml/APKBUILD
+++ b/community/py3-ruamel.yaml/APKBUILD
@@ -2,28 +2,33 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-ruamel.yaml
_pyname=ruamel.yaml
-pkgver=0.16.12
-pkgrel=0
-pkgdesc="A YAML parser/emitter"
-options="!check" # tests are not included in the latest artifact on PyPI
+# XXX: 0.17.29 rewrites tag handling, which breaks use widely
+# if upgrading to a larger version, run the testsuite of aws-cli and borgmatic
+# to verify it is functional.
+pkgver=0.17.28
+pkgrel=1
+pkgdesc="Python YAML parser/emitter"
url="https://sourceforge.net/projects/ruamel-yaml/"
arch="noarch"
license="MIT"
replaces="py-ruamel py3-ruamel"
provides="py-ruamel=$pkgver-r$pkgrel py3-ruamel=$pkgver-r$pkgrel"
depends="py3-ruamel.yaml.clib"
-makedepends="python3-dev py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="py3-pytest py3-ruamel.std.pathlib"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/r/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
+options="!check" # tests are not included in the latest artifact on PyPI
build() {
- python3 setup.py build
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" \
- --single-version-externally-managed
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -36,4 +41,11 @@ check() {
_test/test_*.py
}
-sha512sums="21be4d956d01164b84233c3d3945a4e56351a8fc59c35a8e71b1276da84aa43b125e3860f9884e95a1f895bc53e0b85b6d3f0f4b03512d629a892d8664e3ecd6 ruamel.yaml-0.16.12.tar.gz"
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+5195485270b7a66b228ccfa2956b172cd97712e950f148620d8fb17ba9bf4548a3328229308ffffe970e30fcc73b28ea0ebd2ac571691bc26f1620bcb3183dbe ruamel.yaml-0.17.28.tar.gz
+"