aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rx/APKBUILD')
-rw-r--r--community/py3-rx/APKBUILD43
1 files changed, 31 insertions, 12 deletions
diff --git a/community/py3-rx/APKBUILD b/community/py3-rx/APKBUILD
index f82d2ec1540..d448f0fe6a8 100644
--- a/community/py3-rx/APKBUILD
+++ b/community/py3-rx/APKBUILD
@@ -1,30 +1,49 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-rx
-pkgver=3.2.0
-pkgrel=0
+pkgver=4.0.4
+pkgrel=5
pkgdesc="Reactive Extensions (Rx) for Python"
-url="http://reactivex.io/"
+url="https://reactivex.io/"
arch="noarch"
license="MIT"
-depends="python3"
-makedepends="py3-setuptools py3-pytest-runner"
-checkdepends="py3-pytest py3-coverage py3-pytest-asyncio"
-source="https://github.com/ReactiveX/RxPY/archive/v$pkgver/py3-rx-$pkgver.tar.gz"
+depends="
+ python3
+ "
+makedepends="
+ py3-gpep517
+ py3-poetry-core
+ "
+checkdepends="glib-dev gtk+3.0-dev py3-gobject3 py3-pytest py3-coverage py3-pytest-asyncio"
+subpackages="$pkgname-pyc"
+source="https://github.com/ReactiveX/RxPY/archive/v$pkgver/py3-rx-$pkgver.tar.gz
+ typing-ext.patch
+ "
builddir="$srcdir/RxPY-$pkgver"
+prepare() {
+ default_prepare
+
+ # relied on by publish script
+ sed -i "s|\"0.0.0\"|\"$pkgver\"|" pyproject.toml
+}
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-08a53344ea374b025e51ebf3a7de5ea4e83c7062d0c9a3370b795a56156c8aa068f2b3415f6e5e9e2424a11bcef53a412fd0667afb0016b58b7d2a741ea1007a py3-rx-3.2.0.tar.gz
+5b9f0bf225630d59a899ba5adc89433399e1507e59afa4a0a85423b720b904087f7d578b5b660a43caa09de5ea321faf0f522b7733b1406f9a4354a873672ab0 py3-rx-4.0.4.tar.gz
+b960c2f52477c56ef6641df27b833b0d2d4d095b2ce7ff59c8bd06c3df29097b1dee7b79f3ff568b9d320495634ce937ca85b064c3f7fb553c48dc7bbbb77d21 typing-ext.patch
"