aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-scipy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-scipy/APKBUILD')
-rw-r--r--community/py3-scipy/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-scipy/APKBUILD b/community/py3-scipy/APKBUILD
new file mode 100644
index 00000000000..2ba0a276d71
--- /dev/null
+++ b/community/py3-scipy/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Martell Malone <martellmalone@gmail.com>
+# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
+pkgname=py3-scipy
+pkgver=1.2.1
+pkgrel=4
+pkgdesc="Python library for scientific computing"
+url="https://www.scipy.org"
+arch="all"
+license="BSD-3-Clause"
+depends="py3-numpy-f2py"
+makedepends="cython gfortran openblas-dev>=0.3.0 py3-numpy-dev py3-setuptools
+ python3-dev"
+source="https://github.com/scipy/scipy/releases/download/v$pkgver/scipy-$pkgver.tar.xz"
+builddir="$srcdir"/scipy-$pkgver
+
+replaces=py-scipy # Backwards compatibility
+provides=py-scipy=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ export LDFLAGS="$LDFLAGS -shared"
+ python3 setup.py config_fc --fcompiler=gnu95 build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ebc75c9c40c5accb581c88e42fd3e96a26b42c6bd3785e6e84ace8b1f44fb836c83721c267fcdd9e8f573532056a74b150bde9316da4ac71aa33bd848cc49bd1 scipy-1.2.1.tar.xz"