aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-scrypt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-scrypt/APKBUILD')
-rw-r--r--community/py3-scrypt/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/community/py3-scrypt/APKBUILD b/community/py3-scrypt/APKBUILD
index 3bee490e0c6..9df29628cfe 100644
--- a/community/py3-scrypt/APKBUILD
+++ b/community/py3-scrypt/APKBUILD
@@ -1,19 +1,22 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=py3-scrypt
-pkgver=0.8.18
-pkgrel=0
+pkgver=0.8.20
+pkgrel=5
pkgdesc="Python bindings for the scrypt key derivation function"
url="https://pypi.org/project/scrypt/"
-arch="all"
license="BSD-2-Clause"
+arch="all"
depends="python3"
-makedepends="python3-dev openssl-dev py3-setuptools"
+makedepends="python3-dev openssl-dev py3-gpep517 py3-installer py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/s/scrypt/scrypt-$pkgver.tar.gz"
builddir="$srcdir/scrypt-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -21,10 +24,13 @@ check() {
}
package() {
- python3 setup.py install --skip-build --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/scrypt-*.whl
# do not install the tests module
rm -r "$pkgdir"/usr/lib/python*/site-packages/scrypt/tests
}
-sha512sums="b033203f65dd63c1e915eeff6232c01f806eb01d3ce18e753b6161ae667555095fe775585dd0d4e15ae228f2d4862860093c1a18d5b810b438d032df9fb24d81 scrypt-0.8.18.tar.gz"
+sha512sums="
+da8d34755d4b6c98dc57ff7baf17839cf2434a6d7eb9f6fdc69b3e458d41b4fc49f7fd3a5631318b82bc4b2e46dedb806035897bf1be5a4670b4120f6b46efbc scrypt-0.8.20.tar.gz
+"