aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-send2trash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-send2trash/APKBUILD')
-rw-r--r--community/py3-send2trash/APKBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/community/py3-send2trash/APKBUILD b/community/py3-send2trash/APKBUILD
index 79e7bb348b8..051b2dfb8fd 100644
--- a/community/py3-send2trash/APKBUILD
+++ b/community/py3-send2trash/APKBUILD
@@ -1,26 +1,33 @@
# Contributor: Justin Berthault <justin.berthault@zaclys.net>
-# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=py3-send2trash
-pkgver=1.5.0
+pkgver=1.8.2
pkgrel=2
pkgdesc="Send file to trash natively"
-url="https://github.com/hsoft/send2trash"
+url="https://github.com/arsenetar/send2trash"
arch="noarch"
license="BSD-3-Clause"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/S/Send2Trash/Send2Trash-$pkgver.tar.gz"
-builddir="$srcdir/"Send2Trash-$pkgver
+makedepends="py3-setuptools py3-gpep517 py3-installer py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/arsenetar/send2trash/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/"send2trash-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ pytest tests
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/Send2Trash*.whl
}
-sha512sums="3c08ef513e5707cd4ac82290b326bb19161222c7a84b8ffd494789ba9858929241f55ea55482947af464c14e32fea27bd92cd762a32a1d55e2daf2e21fd63172 Send2Trash-1.5.0.tar.gz"
+sha512sums="
+b750ef75ee7650dd5a7fe3aa18c71e5f812e9b6b238fd80556c1569ba0a5797b1634e53953b5dad6363a224e61cac4a10f6c1b30050228f531015b7fb3d234a1 py3-send2trash-1.8.2.tar.gz
+"