aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-send2trash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-send2trash/APKBUILD')
-rw-r--r--community/py3-send2trash/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/community/py3-send2trash/APKBUILD b/community/py3-send2trash/APKBUILD
index e3a9d1e6c78..051b2dfb8fd 100644
--- a/community/py3-send2trash/APKBUILD
+++ b/community/py3-send2trash/APKBUILD
@@ -1,19 +1,22 @@
# Contributor: Justin Berthault <justin.berthault@zaclys.net>
-# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=py3-send2trash
-pkgver=1.7.1
-pkgrel=0
+pkgver=1.8.2
+pkgrel=2
pkgdesc="Send file to trash natively"
-url="https://github.com/hsoft/send2trash"
+url="https://github.com/arsenetar/send2trash"
arch="noarch"
license="BSD-3-Clause"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-installer py3-wheel"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/arsenetar/send2trash/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/"send2trash-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -21,9 +24,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/Send2Trash*.whl
}
sha512sums="
-fcd69251f27973a1693e1089cb979d6c79e0625c5b88df6c3db9a790fcc845d5a82586871f439f8481d53591ba123680b971b817ee4931e5f439d5df00cdf6a7 py3-send2trash-1.7.1.tar.gz
+b750ef75ee7650dd5a7fe3aa18c71e5f812e9b6b238fd80556c1569ba0a5797b1634e53953b5dad6363a224e61cac4a10f6c1b30050228f531015b7fb3d234a1 py3-send2trash-1.8.2.tar.gz
"