aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-sentry-sdk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-sentry-sdk/APKBUILD')
-rw-r--r--community/py3-sentry-sdk/APKBUILD48
1 files changed, 39 insertions, 9 deletions
diff --git a/community/py3-sentry-sdk/APKBUILD b/community/py3-sentry-sdk/APKBUILD
index 4e980d1753b..b83c65d9583 100644
--- a/community/py3-sentry-sdk/APKBUILD
+++ b/community/py3-sentry-sdk/APKBUILD
@@ -1,30 +1,60 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-sentry-sdk
-pkgver=1.3.0
-pkgrel=0
+pkgver=1.38.0
+pkgrel=1
pkgdesc="The new Python SDK for Sentry.io"
url="https://sentry.io/for/python/"
arch="noarch"
license="BSD-2-Clause"
-options="!check" # test depends on sanic that is not avail atm
-depends="python3 py3-certifi py3-urllib3"
-makedepends="py3-setuptools"
+depends="
+ py3-certifi
+ py3-urllib3
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="
+ py3-executing
+ py3-jsonschema
+ py3-pytest-asyncio
+ py3-pytest-forked
+ py3-pytest-localserver
+ py3-pytest-xdist
+ py3-responses
+ py3-werkzeug
+ "
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/getsentry/sentry-python/archive/$pkgver.tar.gz"
builddir="$srcdir"/sentry-python-$pkgver
+options="!check" # a bunch of deprecation-warning failures and improper shutdown.. seems to need net
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # gcp: pip install
+ # test_socket/test_requests: needs net
+ # wsgi: weird list errors
+ .testenv/bin/python3 -m pytest -n auto -p no:warnings \
+ --deselect tests/integrations/gcp/test_gcp.py \
+ --deselect tests/integrations/socket/test_socket.py \
+ --deselect tests/integrations/requests/test_requests.py \
+ --deselect tests/integrations/wsgi/test_wsgi.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-44e96654a3e4288e63e0fc780ccdf16e5a105ab51af32de146159b9affcc42fbc7004df6673e84369f802e8fdb4e060d1f756945afbe0465dca078d28ad242fb py3-sentry-sdk-1.3.0.tar.gz
+dbdcb7f53ee8da6071befec7a619324c0baabb383bb000875992e82bca97d0f49c7a8836c91a2ae20ae814ed55bf485d01c4762a82761083a19b1db8557d6983 py3-sentry-sdk-1.38.0.tar.gz
"