aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-setuptools-rust/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-setuptools-rust/APKBUILD')
-rw-r--r--community/py3-setuptools-rust/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/community/py3-setuptools-rust/APKBUILD b/community/py3-setuptools-rust/APKBUILD
new file mode 100644
index 00000000000..6e9cc4dad74
--- /dev/null
+++ b/community/py3-setuptools-rust/APKBUILD
@@ -0,0 +1,59 @@
+# Contributor: Aiden Grossman <agrossman154@yahoo.com>
+# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
+pkgname=py3-setuptools-rust
+pkgver=1.9.0
+pkgrel=1
+pkgdesc="Setuptools plugin for rust support"
+url="https://github.com/PyO3/setuptools-rust"
+arch="noarch"
+license="MIT"
+depends="
+ cargo
+ py3-semantic-version
+ py3-setuptools
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools_scm
+ py3-wheel
+ "
+checkdepends="
+ libffi-dev
+ py3-pytest
+ python3-dev
+ "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/PyO3/setuptools-rust/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/setuptools-rust-$pkgver"
+options="net" # check needs network access, no easy patch
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+
+prepare() {
+ default_prepare
+
+ # This test relies on behavior that may be glibc-specific
+ mv -v examples/hello-world/noxfile.py \
+ examples/hello-world/noxfile.py.disabled
+}
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest tests/ setuptools_rust/
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+874bb632a2847cd5febeaa766765ee58432b1a0b96fddfe0fb779f9d7965b726a7c7836e3de6700d801aca1b00a64326ca3de63027069c4a047800bd5d64dfcc py3-setuptools-rust-1.9.0.tar.gz
+"