aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-shapely/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-shapely/APKBUILD')
-rw-r--r--community/py3-shapely/APKBUILD49
1 files changed, 23 insertions, 26 deletions
diff --git a/community/py3-shapely/APKBUILD b/community/py3-shapely/APKBUILD
index ccfae8b68b6..e2a026bbdf5 100644
--- a/community/py3-shapely/APKBUILD
+++ b/community/py3-shapely/APKBUILD
@@ -1,57 +1,54 @@
# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
pkgname=py3-shapely
-pkgver=1.7.1
+pkgver=2.0.4
pkgrel=0
pkgdesc="Manipulation and analysis of geometric objects in the Cartesian plane"
-url="https://pypi.python.org/pypi/Shapely"
-arch="all !s390x !mips !mips64" # geos availability
+url="https://pypi.org/project/Shapely"
+arch="all"
license="BSD-3-Clause"
depends="
py3-numpy
"
makedepends="
+ cython
geos-dev
+ py3-gpep517
py3-matplotlib
py3-numpy-dev
py3-packaging
py3-setuptools
+ py3-wheel
python3-dev
- cython
"
checkdepends="
py3-pytest
"
-source="
- https://pypi.io/packages/source/S/Shapely/Shapely-$pkgver.tar.gz
- 10-packaging.patch
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/s/shapely/shapely-$pkgver.tar.gz
"
-builddir="$srcdir/Shapely-$pkgver"
+builddir="$srcdir/shapely-$pkgver"
build() {
- rm -r _vendor # This is provided by py3-packaging
-
- cython shapely/speedups/_speedups.pyx
- cython shapely/vectorized/_vectorized.pyx
-
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # Tests fail on s390x
- case "$CARCH" in
- s390x) return 0 ;;
- esac
-
- # These examples are executed during test, but they depend on pylab, which is not in Alpine
- rm -r shapely/examples/*
-
- python3 setup.py test
+ mv shapely backup
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -x
+ mv backup shapely
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=2
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+ rm -r "$pkgdir"/usr/lib/python3.*/site-packages/shapely/tests
}
-sha512sums="f5991a35692241ff48f7219edd88bdab7da5b9135c22d26ca530cbdb9160717fd88f2913a9da8ae53869c68955418c14ffd5d798df196639de63660226bd6412 Shapely-1.7.1.tar.gz
-7cebaf4e059d71e1cd374539eb056491afbf736e05bf369a3c6533306885940d108340ada56ec7662e30aac04d2bd3ac4019ccf2fc447151d2274009d93d00fe 10-packaging.patch"
+sha512sums="
+2c6b0a0efc591a9aec2b257209340a4043247a914f4a2482948b4235a1bf34d4fd5e4e01698fbdeef035164c435c3be6c574324b4f4a5ab8f83330682a58bde7 shapely-2.0.4.tar.gz
+"