aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-shlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-shlib/APKBUILD')
-rw-r--r--community/py3-shlib/APKBUILD30
1 files changed, 21 insertions, 9 deletions
diff --git a/community/py3-shlib/APKBUILD b/community/py3-shlib/APKBUILD
index 89e8f224719..f60636f0d09 100644
--- a/community/py3-shlib/APKBUILD
+++ b/community/py3-shlib/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Andy Hawkins <andy@gently.org.uk>
# Maintainer: Andy Hawkins <andy@gently.org.uk>
pkgname=py3-shlib
-pkgver=1.3
-pkgrel=0
+pkgver=1.6
+pkgrel=2
pkgdesc="Shell Library"
url="https://nurdletech.com/linux-utilities/shlib/"
arch="noarch"
@@ -12,24 +12,36 @@ depends="
py3-braceexpand
py3-inform
"
-makedepends="py3-setuptools py3-pytest-runner"
-checkdepends="py3-pytest"
+makedepends="
+ py3-flit-core
+ py3-gpep517
+ py3-installer
+ "
+checkdepends="
+ py3-pytest
+ "
+subpackages="$pkgname-pyc"
source="https://github.com/KenKundert/shlib/archive/v$pkgver/shlib-v$pkgver.tar.gz"
builddir="$srcdir/shlib-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- sed -i 's|env python|env python3|g' tests/test_prog
- PYTHONPATH="$PWD/build/lib" pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ cd .testenv
+ bin/python3 -m pytest ..
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-5ec01b4fbecd20e3ba5d61b066874d1422a9bda8a6513c4c9a18cb25fc46cb986416e77f76d73af554f3683c1b6e50444701743c4b00cb9a88fc43da694a97d1 shlib-v1.3.tar.gz
+6a3b86bf16debc01e4c1ea87ed176c1d520014b278c873448ecd746470fc6bbed7368dc423a1943af0b7e7c9e0f7b2c844771a7899e123c754e666be6c1d161f shlib-v1.6.tar.gz
"