aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-simplejson/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-simplejson/APKBUILD')
-rw-r--r--community/py3-simplejson/APKBUILD34
1 files changed, 22 insertions, 12 deletions
diff --git a/community/py3-simplejson/APKBUILD b/community/py3-simplejson/APKBUILD
index a63015b86c0..e420242e427 100644
--- a/community/py3-simplejson/APKBUILD
+++ b/community/py3-simplejson/APKBUILD
@@ -1,34 +1,44 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-simplejson
-_pkgname=simplejson
-pkgver=3.17.5
-pkgrel=0
+pkgver=3.19.2
+pkgrel=1
pkgdesc="Simple, fast, extensible JSON encoder/decoder for Python"
-url="https://pypi.python.org/pypi/simplejson"
+url="https://github.com/simplejson/simplejson"
arch="all"
license="MIT"
depends="python3"
-makedepends="py3-setuptools python3-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/simplejson/simplejson/archive/v$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+subpackages="$pkgname-pyc"
+source="https://github.com/simplejson/simplejson/archive/refs/tags/v$pkgver/simplejson-v$pkgver.tar.gz"
+builddir="$srcdir"/simplejson-$pkgver
provides="py-simplejson=$pkgver-r$pkgrel" # backwards compatibility
replaces="py-simplejson" # backwards compatiblity
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m unittest discover
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
- rm -Rf "$subpkgdir"/usr/lib/python*/site-packages/simplejson/tests/
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+ rm -rf "$pkgdir"/usr/lib/python*/site-packages/simplejson/tests/
}
sha512sums="
-cfde404fd896030a65749f2c29c9d9e603e51c90b977777caa7749d8fa0c400ff6cf7d49c23afd650aaffddaa6407ac6d68454caa0ea703410a84f38cb6a5bed py3-simplejson-3.17.5.tar.gz
+6fc1967c5620d1a0492c591aa8b0b1d47839d492f63b030fb172402343fab754fb46e4baebaf5d84f1d30c357bbc325b05003cd5e92aabfdf6ad4ac003161452 simplejson-v3.19.2.tar.gz
"