aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-skia-pathops/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-skia-pathops/APKBUILD')
-rw-r--r--community/py3-skia-pathops/APKBUILD45
1 files changed, 34 insertions, 11 deletions
diff --git a/community/py3-skia-pathops/APKBUILD b/community/py3-skia-pathops/APKBUILD
index 388abfae338..320110ba62f 100644
--- a/community/py3-skia-pathops/APKBUILD
+++ b/community/py3-skia-pathops/APKBUILD
@@ -1,28 +1,51 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-skia-pathops
-pkgver=0.2.1
-pkgrel=1
+pkgver=0.7.4
+pkgrel=3
pkgdesc="Python bindings for the Skia library's Path Ops"
url="https://github.com/fonttools/skia-pathops"
-arch="all !s390x !mips !mips64" # doesn't support big endian
+arch="all !s390x" # doesn't support big endian
license="BSD-3-Clause"
depends="python3 cython"
-makedepends="python3-dev py3-setuptools py3-setuptools_scm"
-options="!check" # missing deps: pytest-cython, pytest-randomly
-source="https://files.pythonhosted.org/packages/source/s/skia-pathops/skia-pathops-$pkgver.zip"
+makedepends="
+ gn
+ py3-gpep517
+ py3-setuptools
+ py3-setuptools_scm
+ py3-wheel
+ python3-dev
+ samurai
+ "
+checkdepends="py3-pytest-xdist"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/s/skia-pathops/skia-pathops-$pkgver.zip
+ gn-ninja.patch
+ cpdef.patch
+ "
builddir="$srcdir/skia-pathops-$pkgver"
+options="net"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --config-json '{"no-fetch-gn": true}' \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto -p no:warnings
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="ed4deba9e6e3576cc4c550c0c0172b0780f1e8e1424f156e8ef893a62924fd91c16a3bf2e1598c3116a1a73958513339dce48a2978f86b27f285d6f0f50245eb skia-pathops-0.2.1.zip"
+sha512sums="
+71df9b0b237a70af2246a30d53e201da493deb7a098dd969c346745c60997df1aeb1b20d4c94c2443b1c710c464272b44e9225d58ac3a9fd1074816839ae797b skia-pathops-0.7.4.zip
+1df0382cfb70a7cacad2ed68b6fe50c47835d613045ab2a3b403c02b7d16e88606adbd2b3f4db01afd7998673b4844632fe2405aa2d234917fd59e7de41ae595 gn-ninja.patch
+da8f09ddd0afce3fca2f9d812d145825a42a4895a8b36e1ddc9ce34c2bf372b0e15eff6a028139ae981f99abb608b5faa2592f036fbaf90e1b14432b4a6180eb cpdef.patch
+"