aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-slugify/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-slugify/APKBUILD')
-rw-r--r--community/py3-slugify/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/py3-slugify/APKBUILD b/community/py3-slugify/APKBUILD
index 520741581c6..d3e1ecb8614 100644
--- a/community/py3-slugify/APKBUILD
+++ b/community/py3-slugify/APKBUILD
@@ -1,20 +1,22 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=py3-slugify
-_pkgname=python-slugify
-pkgver=5.0.2
-pkgrel=0
-pkgdesc="A Python slugify application that handles unicode"
+pkgver=8.0.4
+pkgrel=1
+pkgdesc="Python module for creating slugs from unicode strings"
url="https://github.com/un33k/python-slugify"
-arch="noarch"
license="MIT"
-depends="python3 py3-text-unidecode"
-makedepends="py3-setuptools"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/un33k/python-slugify/archive/$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+arch="noarch"
+depends="python3 py3-unidecode"
+makedepends="py3-gpep517 py3-installer py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
+source="https://github.com/un33k/python-slugify/archive/v$pkgver/py3-slugify-$pkgver.tar.gz"
+builddir="$srcdir/python-slugify-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -22,9 +24,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+ python3 -m installer -d "$pkgdir" \
+ .dist/python_slugify-$pkgver-py3-none-any.whl
}
sha512sums="
-79cdd1d0312c9e34b07dca2e898f177a85b31d3f290403375032ae962df61f3a9c4167f4bdf10f47afd17d544731d6961810f8a081ef615d76d8758c1207e6b7 python-slugify-5.0.2.tar.gz
+b401e574f23fa77152f8c64f15263766ed7d081759e93c28fce5fa32495eb4921701030b395ca1c738ca46a509e54bc987d81ff07fa602dd42bfa630a49aa4a0 py3-slugify-8.0.4.tar.gz
"