aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-smmap2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-smmap2/APKBUILD')
-rw-r--r--community/py3-smmap2/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/py3-smmap2/APKBUILD b/community/py3-smmap2/APKBUILD
new file mode 100644
index 00000000000..35d1ee47924
--- /dev/null
+++ b/community/py3-smmap2/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
+pkgname=py3-smmap2
+pkgver=5.0.1
+pkgrel=1
+# 6.0.0 was yanked and replaced with 5.0.1, should not be upgraded to
+pkgdesc="pure Python3 implementation of a sliding window memory map manager"
+url="https://github.com/gitpython-developers/smmap"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gitpython-developers/smmap/archive/v$pkgver.tar.gz"
+builddir="$srcdir/smmap-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+0c8b880ab621d42303a9a11528f3c0ca4ece2b48670cbc6524e765d208078c095cb2e1b4d67761926e9871a51bd4609c17b80d1c776772ab2436c4337a199f06 py3-smmap2-5.0.1.tar.gz
+"