aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-sniffio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-sniffio/APKBUILD')
-rw-r--r--community/py3-sniffio/APKBUILD25
1 files changed, 18 insertions, 7 deletions
diff --git a/community/py3-sniffio/APKBUILD b/community/py3-sniffio/APKBUILD
index 31cb76b98bd..325ad975d46 100644
--- a/community/py3-sniffio/APKBUILD
+++ b/community/py3-sniffio/APKBUILD
@@ -1,24 +1,35 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-sniffio
-pkgver=1.1.0
-pkgrel=0
+pkgver=1.3.1
+pkgrel=1
pkgdesc="Sniff out which async library your code is running under"
url="https://github.com/python-trio/sniffio"
arch="noarch"
license="MIT OR Apache-2.0"
-depends="python3 py3-curio"
-makedepends="py3-setuptools"
+depends="py3-curio"
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/s/sniffio/sniffio-$pkgver.tar.gz"
options="!check" # No tests
builddir="$srcdir/sniffio-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="f315c79245ccec8e1e6e0f8ffe4cf42fdab7f5fe3e680ddc05c65732a6d26989ac1459135f13938380928b02802bc0a6b1174c83118a60b0ad15f59730927912 sniffio-1.1.0.tar.gz"
+sha512sums="
+210b60224b54b20153059c3419951156fff41dc32876ed0b0640dd5dfb600ce324e0fc0b0c20a3467baa3e5383bf3157b99f22fd5bfe7ec3321aca6b166ce1af sniffio-1.3.1.tar.gz
+"