aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-softlayer-zeep/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-softlayer-zeep/APKBUILD')
-rw-r--r--community/py3-softlayer-zeep/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/py3-softlayer-zeep/APKBUILD b/community/py3-softlayer-zeep/APKBUILD
new file mode 100644
index 00000000000..cdd94f3de8c
--- /dev/null
+++ b/community/py3-softlayer-zeep/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Duncan Bellamy <dunk@denkimushi.com>
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
+pkgname=py3-softlayer-zeep
+pkgver=5.0.0
+pkgrel=2
+pkgdesc="modern/fast Python SOAP client based on lxml / requests"
+url="https://docs.python-zeep.org/en/master/"
+arch="noarch"
+license="MIT"
+depends="
+ py3-attrs
+ py3-isodate
+ py3-lxml
+ py3-platformdirs
+ py3-requests
+ py3-requests-file
+ py3-requests-toolbelt
+ py3-tz
+ "
+makedepends="py3-setuptools"
+checkdepends="py3-freezegun py3-pretend py3-pytest py3-pytest-asyncio py3-pytest-httpx py3-requests-mock"
+# test deps not available
+if [ "$CARCH" = "armhf" ] || [ "$CARCH" = "ppc64le" ]; then options="!check"; fi
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/s/softlayer-zeep/softlayer-zeep-$pkgver.tar.gz"
+builddir="$srcdir/softlayer-zeep-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH=build/lib python3 -m pytest
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+8dc85f7692410068fb1b6d1de9c8f7c6e03125773fb6b80de127642dd7303107f14cbe9d175b0a316b4a15697e8ffc3a91077fda1edf625ce5614abc6fd5489e softlayer-zeep-5.0.0.tar.gz
+"