aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-softlayer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-softlayer/APKBUILD')
-rw-r--r--community/py3-softlayer/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/py3-softlayer/APKBUILD b/community/py3-softlayer/APKBUILD
index 22ee9063d83..1a91f086303 100644
--- a/community/py3-softlayer/APKBUILD
+++ b/community/py3-softlayer/APKBUILD
@@ -1,34 +1,37 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-softlayer
-pkgver=5.9.6
-pkgrel=0
+pkgver=6.1.11
+pkgrel=1
pkgdesc="library for SoftLayer's API"
url="https://github.com/softlayer/softlayer-python"
arch="noarch"
license="MIT"
-depends="py3-click py3-prompt_toolkit py3-ptable py3-pygments py3-requests py3-urllib3"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-pytest-mock py3-testtools"
+depends="py3-click py3-prompt_toolkit py3-prettytable3 py3-pygments py3-requests py3-rich py3-urllib3"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest py3-pytest-mock py3-testtools py3-softlayer-zeep python3-tkinter"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/softlayer/softlayer-python/archive/v$pkgver.tar.gz"
builddir="$srcdir/softlayer-python-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- #py3tkinter needed for this test
- python3 -m pytest \
- --deselect=tests/CLI/environment_tests.py::EnvironmentTests::test_getpass_issues1436
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
rm -rf "$pkgdir"/usr/lib/python3*/site-packages/tests
}
sha512sums="
-ffdc995e8231cc3c1662683a219500f8da52bda135338a7d9236d2c23d263dda447f52b1a80e6721b0951641650c8a132c49b3400a221a2aeefb50091c33174e py3-softlayer-5.9.6.tar.gz
+8c1551bb3eea53b95d5f38fcb8a6220883a2aca4a0d85481145d259f9d822858417131e4e2083d1c626c404539690f14b3003d07d8429209e1c831241157ac48 py3-softlayer-6.1.11.tar.gz
"