aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ssdeep/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ssdeep/APKBUILD')
-rw-r--r--community/py3-ssdeep/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/py3-ssdeep/APKBUILD b/community/py3-ssdeep/APKBUILD
new file mode 100644
index 00000000000..f85af4c415e
--- /dev/null
+++ b/community/py3-ssdeep/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=py3-ssdeep
+pkgver=3.4.1
+pkgrel=3
+pkgdesc="Python wrapper for ssdeep fuzzy hashing library"
+url="https://github.com/DinoTools/python-ssdeep"
+arch="all"
+license="LGPL-3.0-or-later"
+depends="python3 py3-cffi py3-six"
+makedepends="python3-dev py3-setuptools libfuzzy2-dev py3-wheel"
+checkdepends="py3-pytest py3-pytest-runner"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/DinoTools/python-ssdeep/archive/$pkgver.tar.gz
+ pytest-runner.patch"
+builddir="$srcdir/python-ssdeep-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+7b0fdde76e0fa76caa5bebc145bab16406f15bad34f455c3dfe8709003d06ae7def5b6d3130cdcbbeff54262a8fe39f2931cf3156a0cf1f4cc7126f4db190575 py3-ssdeep-3.4.1.tar.gz
+aacd3eaa40b070523f67360df576afa336d4012262ee5bb687be6a3eac7a85050e37d37a1afa88b1889c653ab2e22ee682553aeabf5be3d56120d9b27ab71591 pytest-runner.patch
+"