aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-stack_data/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-stack_data/APKBUILD')
-rw-r--r--community/py3-stack_data/APKBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/community/py3-stack_data/APKBUILD b/community/py3-stack_data/APKBUILD
index db54073d831..e60bcec1454 100644
--- a/community/py3-stack_data/APKBUILD
+++ b/community/py3-stack_data/APKBUILD
@@ -1,36 +1,45 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-stack_data
-pkgver=0.1.3
-pkgrel=0
+pkgver=0.6.3
+pkgrel=1
pkgdesc="library that extracts data from stack frames and tracebacks"
url="https://github.com/alexmojaki/stack_data"
arch="noarch"
license="MIT"
depends="python3 py3-executing py3-asttokens py3-pure_eval"
-makedepends="py3-build py3-installer py3-wheel py3-setuptools_scm"
-checkdepends="py3-pytest py3-typeguard"
-options="!check" # requires unpackaged littleutils
+makedepends="py3-gpep517 py3-setuptools_scm py3-wheel"
+checkdepends="
+ cython
+ py3-littleutils
+ py3-pygments
+ py3-pytest
+ py3-typeguard
+ py3-typing-extensions
+ python3-dev
+ "
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/alexmojaki/stack_data/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/stack_data-$pkgver"
build() {
export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
- python3 -m build \
- --no-isolation \
- --wheel \
- .
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- local whl=dist/stack_data-$pkgver-py3-none-any.whl
+ local whl=.dist/stack_data-$pkgver-py3-none-any.whl
python3 -m installer --dest="$pkgdir" "$whl"
}
sha512sums="
-9a88ccf668017f661c00962d643794c481a4eccc0b47bbd250aa3ac2374c14544af65479f2455357566e0220eeb2a4d41241a7bc0e478461e9eaff8f0b2a889d py3-stack_data-0.1.3.tar.gz
+ac2f5021b57f29667490c17e83d1dfd1ac5199eda6319fb52882d6cd93adfe532a45ca2f86c864ebcb23586a1cc6297cc33e8a2b073db7fdc3382bec55d03065 py3-stack_data-0.6.3.tar.gz
"