aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-svgwrite/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-svgwrite/APKBUILD')
-rw-r--r--community/py3-svgwrite/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/py3-svgwrite/APKBUILD b/community/py3-svgwrite/APKBUILD
new file mode 100644
index 00000000000..4fec859c569
--- /dev/null
+++ b/community/py3-svgwrite/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Alex Denes <caskd@redxen.eu>
+# Maintainer: Alex Denes <caskd@redxen.eu>
+_pkgname=svgwrite
+pkgname="py3-$_pkgname"
+pkgver=1.4.3
+pkgrel=2
+pkgdesc="Python library to create SVG drawings"
+url="https://github.com/mozman/svgwrite"
+arch="noarch"
+license="MIT"
+depends="
+ py3-parsing
+"
+makedepends="py3-setuptools_scm"
+checkdepends="
+ py3-pytest
+"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mozman/svgwrite/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m pytest tests
+}
+
+package() {
+ python3 setup.py install --root "$pkgdir"
+}
+
+sha512sums="
+3e599c13c2138aec1f9098baf3cf978b477f45ec2acd14d6aaadbcdf952064dac6313fd26050e670e9e989867c3539fa1cc7fb1cd226e34ff9f2a1ca2e7ddeff py3-svgwrite-1.4.3.tar.gz
+"