aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-sybil/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-sybil/APKBUILD')
-rw-r--r--community/py3-sybil/APKBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/community/py3-sybil/APKBUILD b/community/py3-sybil/APKBUILD
index 8dd73a031bb..8f94fd4a306 100644
--- a/community/py3-sybil/APKBUILD
+++ b/community/py3-sybil/APKBUILD
@@ -1,37 +1,46 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
pkgname=py3-sybil
-pkgver=2.0.1
-pkgrel=2
+pkgver=6.0.3
+pkgrel=1
pkgdesc="Automated testing for the examples in your documentation"
-url="https://github.com/cjw296/sybil"
+url="https://github.com/simplistix/sybil"
arch="noarch"
license="MIT"
-depends="python3"
makedepends="
- py3-nose
+ py3-gpep517
py3-setuptools
py3-sphinx
py3-wheel
"
-checkdepends="py3-pytest"
-source="https://pypi.python.org/packages/source/s/sybil/sybil-$pkgver.tar.gz
- fix-tests-for-python-3-10.patch"
+checkdepends="
+ py3-pytest
+ py3-seedir
+ py3-testfixtures
+ py3-yaml
+ "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/simplistix/sybil/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/sybil-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" pytest --deselect tests/test_doc_example.py::test_pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -k 'not test_pytest'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
+
sha512sums="
-4f3be7686c1acf6812623a756fa79b41e3fbe5d4c3b4c7cf5dfe39fbe56806b4ef3acd24e25968ab9119b2c65ad5c30eabe32f1a93fb62ba8d3893ef123e69f0 sybil-2.0.1.tar.gz
-1dc373b048828e37a73dd6130b4b70d06f99eb670a3d2da6c63e917f32f87fe1c5a20fa7f495e6c579b6c0057073d41d399d67e05bc9abd37f338e1636e05b84 fix-tests-for-python-3-10.patch
+1fb42b944b237556012ace6fcc5eb3d0f067f0ca043ceafa0e201a8076870fc7e06ae62813eec90d486de6e4b71ebf29176dfff6573de423480c688ff005004d py3-sybil-6.0.3.tar.gz
"