aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-tcxparser/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-tcxparser/APKBUILD')
-rw-r--r--community/py3-tcxparser/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/py3-tcxparser/APKBUILD b/community/py3-tcxparser/APKBUILD
new file mode 100644
index 00000000000..5bd2d421ab8
--- /dev/null
+++ b/community/py3-tcxparser/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+pkgname=py3-tcxparser
+_pkgorig=python-tcxparser
+pkgver=2.3.0
+pkgrel=5
+pkgdesc="Simple parser for Garmin TCX files"
+url="https://github.com/vkurup/python-tcxparser"
+arch="noarch"
+license="BSD-2-Clause"
+depends="python3 py3-lxml py3-dateutil"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest-xdist"
+subpackages="$pkgname-pyc"
+source="https://github.com/vkurup/python-tcxparser/archive/$pkgver/$_pkgorig-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgorig-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+6a145ee69f5398683e15216bcee61bac431aeb03dd3b4e09be075e0543b6b5afdb028757918e73da70d514de727b1c7895496da35f9ee47a7fce371d7397f648 python-tcxparser-2.3.0.tar.gz
+"