aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-telethon-session-sqlalchemy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-telethon-session-sqlalchemy/APKBUILD')
-rw-r--r--community/py3-telethon-session-sqlalchemy/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/py3-telethon-session-sqlalchemy/APKBUILD b/community/py3-telethon-session-sqlalchemy/APKBUILD
new file mode 100644
index 00000000000..db9b8e0e3a0
--- /dev/null
+++ b/community/py3-telethon-session-sqlalchemy/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-telethon-session-sqlalchemy
+pkgver=0.2.16
+pkgrel=5
+pkgdesc="SQLAlchemy backend for Telethon session storage"
+url="https://github.com/tulir/telethon-session-sqlalchemy"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="https://pypi.python.org/packages/source/t/telethon-session-sqlalchemy/telethon-session-sqlalchemy-$pkgver.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/telethon-session-sqlalchemy-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="2d78aa821af9199cc5ce8c1ad31088f2a43287ec4fced3e1a8b5a667b4dd93df091d07ef661081fcebf81d9dc33d821773aa3d680608b6351cc642774f808712 telethon-session-sqlalchemy-0.2.16.tar.gz"