aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-tempita/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-tempita/APKBUILD')
-rw-r--r--community/py3-tempita/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/community/py3-tempita/APKBUILD b/community/py3-tempita/APKBUILD
index a11e6a72f5e..d04bbc1922b 100644
--- a/community/py3-tempita/APKBUILD
+++ b/community/py3-tempita/APKBUILD
@@ -3,15 +3,18 @@
pkgname=py3-tempita
_pkgname=Tempita
pkgver=0.5.2
-pkgrel=8
+pkgrel=13
pkgdesc="A small templating language"
-url="https://pypi.python.org/pypi/Tempita"
+url="https://pypi.org/project/Tempita"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
options="!check" #no testsuite
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ setuptools59.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
replaces=py-tempita # Backwards compatibility
@@ -23,7 +26,10 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="582d3ca35dfb2ad44491cf9e526db9f9c34c419f2b03a5ce86a7e5183f7760b380262367c062161d577c3fb3e69e39ee99bbf8e493873e1da1a350ef2f63630d Tempita-0.5.2.tar.gz"
+sha512sums="
+582d3ca35dfb2ad44491cf9e526db9f9c34c419f2b03a5ce86a7e5183f7760b380262367c062161d577c3fb3e69e39ee99bbf8e493873e1da1a350ef2f63630d Tempita-0.5.2.tar.gz
+6e228a9fe565ee881e4ecf1e554c34f3efc33da480ca3c31c5bf19e040134547e60bdf0624b99accf8ff277e2b9772a80d2be849c55d7bb4f7a3e0f309800a1c setuptools59.patch
+"